2 Gx Gearbox Lock Up Help!!!!

Discussion in 'Gun Building, Modifications & Repairs' started by kwasr10, Oct 13, 2012.

  1. kwasr10

    kwasr10 New Member

    21
    0
    I have a Kwa Sr10 and i recently upgraded it with a new G&P m170 motor, G&G m130 spring, G&G polycarb piston, Systema duracon piston head, Sw-Cheetah progammable mosfet, G&P amuminum cylinder head, and Edgi 6.01mm Tight bore barrel. All of my parts seem to be compatable with my gun but the problem is that the piston gets pulled back to what appears to be pulled all the way back, (around 4-5 milimeters left) and it just locks up, the motor won't spin at all. This has happened all three times i have tested it, i have even tried a guarder sp130 spring in it and the same thing happened. Then i put the old spring back in it and it fires but always locks up and the motor won't spin. the original spring is an m120 and it is so worn out that my gun shoots in the 280-300 fps range and i do not like that at all. i also use 9.6v numchuck batteries that are brand knew, they cannot be the problem because i have tried all 6 of them. I don't know what the problem is, is the gear getting stuck on the last piston tooth? Is the spring too big to compress?
    Please Help
     
  2. Axis

    Axis Active Member Supporting Member

    1,808
    21
    You. Do. Not. Upgrade. KWA. Guns.

    I can't stress this enough... There are so many people out there that try to put aftermarket parts in a KWA. They all mostly fail. There should be a sticker on the GB or hop-up unit saying "Do not break seal". I would've followed its instructions. I would just try to put the original parts back in if I were you.
     

  3. Mystery43_4

    Mystery43_4 New Member

    1,307
    2
    Santa Barbara
    Use a larger battery. There is all sorts of wrong with your build, but to avoid the lock ups, use a more powerful battery.
     
  4. TheBadGuy

    TheBadGuy New Member

    17
    0
    merritt island
    I had the same issue when I tried to install an shs m130 spring. I kept all the parts stock though. I couldn't figure out the problem. I am using a 9.6v battery. I think I need to go to an 11.1v lipo. Post here if you figure out the problem. I have a sr10 as well. Completely stock.
     
  5. EDI1st

    EDI1st New Member

    2,062
    3
    Fountain Valley
    I know the exact reason why it happened.
    It's a KWA.