Celcius CTW (electrical?) problem.

Discussion in 'Gun Building, Modifications & Repairs' started by MadSpartan, Oct 18, 2012.

  1. MadSpartan

    MadSpartan New Member

    13
    0
    Winston-Salem
    Hi guys, I've recently acquired a Celcius CTW from a boneyard hoping to fix it up. When I bought it I was hoping it would be something simple, like a wiring issue. I'm almost positive it is, because when I plug in a battery, there is no sound of anything trying to move in the gearbox and there is no blue light on the inside of the gearbox. I don't know how many times I've checked over all of the wiring, but it all looks perfect, no jagged or spliced wires & the connections all look fine. I hope someone out there can help me with this problem, It would be greatly appreciated. (btw, I am an airsoft tech and have been repairing guns for almost three years at my fathers' store, but this gun just has me puzzled.)
     
  2. Dark-Knight10

    Dark-Knight10 New Member

    134
    0
    1. Check the fuse. Looks like your fuse blow out, that's why you don't see the blue light on. That what i would start from first. Let us know if you fix your CTW.
     

  3. MadSpartan

    MadSpartan New Member

    13
    0
    Winston-Salem
    Yeah, I forgot to mention that. The fuse, wiring, & motor/trigger connections are always the first thing I check. Thanks for the suggestion though.
     
  4. Dark-Knight10

    Dark-Knight10 New Member

    134
    0
    If you checked the wire, the fuse already, and you don't see the blue lights on, i think the ECU Control Unit has problem. Have you check the sector gear if it's locked? To do that, you have to take the motor out and then spin the sector gears to see if anything wrong with the gearbox. If you can't spin, that means the gearbox locked, and you have to open the gearbox to check it out. Good luck