DSG and GateTitan issues

Discussion in 'Gun Building, Modifications & Repairs' started by aaron izadi, Nov 26, 2020.

  1. aaron izadi

    aaron izadi New Member

    7
    1
    union city
    Currently working on my dsg build to get it skirmish-able. Everything seems to work well at ~50rps aside from expected "midcap syndrome" and overspin.

    When using pts epm's filled to the max feeding becomes sparse and jamming can occur, When using normal midcaps feeding is fine and jamming does not occur but fps dips in the 340-360 range occur time to time before going back to the 390-395 range. Note that gearbox compression is perfect and that gearbox to hopup compression should be good. I've cut the tappet plate down quite a bit and I'm not sure I can really cut any more coils off the return spring. The front of the tappet has been sanded as well. I think its worth noting that there is way too much resistance between the nozzle and cylinder head as it gets gummy near the end of the nozzles travel path(replacements coming) but it doesn't seem to matter when I dryfire test it. My return spring also has a huge bend in the middle so I'm gonna replace it and see if thats causing any issues.

    Now with the gate titan even at 100% AB I will get over-spin here and there which is a huge pain to deal with. It seems to only happen when the motor is warm but on any other AB setting it will occur every few shots(1 in 10-20?). This over-spin problem also seems to be kind of recent as I've been working on this gearbox for almost 2 weeks now and just started experiencing it. I have no real idea what it could be and will just have to check the board seating and sensors for grease I guess.


    Parts List:
    RA split gearbox
    ZCI alu cylinder
    No name cylinder head
    SHS nozzle(unknown length)
    SHS swiss cheesed piston faucet washered for AOE
    Random POM piston head
    trimmed+front shaved shs tappet plate(5 coils removed from return spring)
    SHS DSG/16:1 spur-bevel
    Gate titan
    ActionArmy 15tpa motor
    Prommy M170
    prommy ARL
    RA trigger
    1300mah 75c 11.1vlipo
    r-hopped zci barrel/promy purple paired with maxx unit
     
    Last edited: Nov 26, 2020
  2. danerd

    danerd Well-Known Member

    794
    858
    Ozark
    A full parts list would be beneficial so its easier to gauge everything in the build.

    Overspin is usually caused by a multitude of factors: weaker main spring, poor cutoff mechanism, or too fast of a motor/gear pairing along with a good battery. Lets assume that none of these are causing the issue for now.

    Being the Titan uses an optical cycle sensor, it may be the sector gear is not tripping the sensor at times. Check the sensor for excess lubricant and clean if needbe. You can also take some very fine (1000+) steel wool and remove the coating on the cam on the bottom of the sector gear. This will polish the cam to make it more reflective and may help in tripping the sensor. You'll also want to tweak the settings on the Titan and make sure its set to DSG mode. You may also want to check the sensitivity on the cycle detection and change that if you can.
     
    Ben3721 likes this.

  3. aaron izadi

    aaron izadi New Member

    7
    1
    union city
    Updated the parts list more and yea I'll definitely have to check the titan for excess grease. DSG mode is on as well. Also the bottom of the sector gear cam? I should know what that is but im drawing a blank.
     
  4. danerd

    danerd Well-Known Member

    794
    858
    Ozark
    Its the small "hook" or nub on the bottom of the sector gear that normally engages the cutoff lever during each cycle.

    You'll want to clean the sensor(s) with a 70% isopropyl alcohol solution and cotton swab so there is no grease/lubricant film left that may interfere with readings ;)
     
  5. Brogan Smith

    Brogan Smith New Member

    6
    0
    Snellville
    I had overspin and of all things setting my titan to low speed gears solved the issue (16:1 SHS DSG gears) I dont understand how but it worked
     
  6. danerd

    danerd Well-Known Member

    794
    858
    Ozark
    Adjusting the setting on the Titan changed the cycle detection setting on the firmware. Most DSGs (in the day) were run off of Riot sets of gears. Those typically came in 10.44, 14.2, and 20.16 ratios. Granted, the exact ratios differ slightly between 8 and 9 tooth sets. 16:1 sits right between 14 and 20:1 ratio sets and it makes sense you would have to delve into the settings and tweak accordingly.
     
  7. aaron izadi

    aaron izadi New Member

    7
    1
    union city
    Yup this is most likely the issue. When cleaning the sensors I noticed the screw had nearly completely let itself go. I've applied threadlocker and tightened it since and double shooting has become very rare @ 60% active breaking. At this point I just have to work on the fps consistancy which drops 20-30 fps on certain mags time to time.