fuse keeps blowing

Discussion in 'Gun Building, Modifications & Repairs' started by English, Jan 15, 2012.

  1. English

    English New Member

    247
    0
    upton
    i have a JG M4 and i keep blowing the fuse, why is this would it be the motor is in wrong, exposed wiring, help me please.
     
  2. UnitedIslands

    UnitedIslands New Member

    172
    0
    How many fuses have you blown? Make sure you don't use the stock one or ones made in China that are cheap, just go to you local hardware store, show a blown fuse to an employee and they can direct you to the right fuses to buy, hope I helped:)
     

  3. English

    English New Member

    247
    0
    upton
    3 so far, the one that came with the gun and 2 i got from the store, gun fired slowly then died, checked fuse and it was blown, why would this be happening, did i put the motor back in wrong
     
  4. mck

    mck New Member

    7
    0
    Your motor might be bad.
     
  5. mck

    mck New Member

    7
    0
    Or too much pressure on the motor.
     
  6. Thatguyoverthere1111

    Thatguyoverthere1111 New Member

    4,838
    0
    Mandeville
    Usually blown fuses are caused by stress on the gun. If you just let loose and go crazy, your motor can overheat and blow the fuse. Unless you are just the most unlucky person on the planet and got a bunch of bad fuses.
     
  7. English

    English New Member

    247
    0
    upton
    too much pressure on the motor ??

    what do you mean
     
  8. Thatguyoverthere1111

    Thatguyoverthere1111 New Member

    4,838
    0
    Mandeville
    Basically what I said. Don't go crazy with the gun, you're most likely stressing the gun. What gun is it exactly?
     
  9. English

    English New Member

    247
    0
    upton
    JG M4 it fired off 20 rounds and died.
     
  10. Mystery43_4

    Mystery43_4 New Member

    1,307
    0
    Santa Barbara
    What battery are you using?
    What Amp fuse are you using?
    Have you tried a different battery?
    Is your fuse blowing the first time that you pull the trigger, or does it take a little while?
    Do your battery, wires, and motor heat up before it blows?
     
  11. English

    English New Member

    247
    0
    upton
    What battery are you using? 8.4v 1100mah
    What Amp fuse are you using? F20AL250V
    Have you tried a different battery? Yep same problem
    Is your fuse blowing the first time that you pull the trigger, or does it take a little while? Takes 10 sec
    Do your battery, wires, and motor heat up before it blows? not that i notice but the motor is very magnetic, never noticed this before.
    __________________
     
  12. Thatguyoverthere1111

    Thatguyoverthere1111 New Member

    4,838
    0
    Mandeville
    Most motors are magnetic. My JG M4's motor is magnetic and my fuse is fine.
     
  13. English

    English New Member

    247
    0
    upton
    noticed some exposed wiring would this cause the fuse to blow
     
  14. Thatguyoverthere1111

    Thatguyoverthere1111 New Member

    4,838
    0
    Mandeville
    Where was it exposed? Is the gun wired to the handgaurd or the stock?
     
  15. English

    English New Member

    247
    0
    upton
    it was exposed near the battery, i think i may have pinched it when i closed the cover down on the battery, battery fits in stock in front of the mag, i think the exposed wires were touching the metal stock.
     
  16. Thatguyoverthere1111

    Thatguyoverthere1111 New Member

    4,838
    0
    Mandeville
    Wait what? The battery goes in the stock, but in front of the mag? What? I think you mean the handguard, or you have a very unique M4...
     
  17. English

    English New Member

    247
    0
    upton
    yeah handguard anyway would the exposed wire touching the metal handguard cause the fuse to blow.
     
  18. Thatguyoverthere1111

    Thatguyoverthere1111 New Member

    4,838
    0
    Mandeville
    No, it shouldn't. Unless of course the exposed wire is the actual copper wire and not the wire with the covering over it. Try using a different motor, that might help.
     
  19. milkshake38

    milkshake38 New Member

    298
    0
    irvine
    Did you open your gun up(gearbox)? Cause you might have shimmed it wrong. For the motor, the red side (+) need to be towards the barrel of the gun.

    You say that your motor might be in wrong so that's why I was asking.
     
  20. Bair

    Bair New Member

    1
    0
    Hanover
    I have a MTC2 and I blew about 6 in a row. the fuse turns blue and then burns. I have a 8.4v battery and the wires don't get hot. Can someone tell me what I should check.