Featured G&G Mp5 Feeding Issues... again.

Discussion in 'Gun Building, Modifications & Repairs' started by Noah_6, Jan 11, 2021.

  1. Noah_6

    Noah_6 Active Member

    1,041
    7
    Burbank
    I've been working on rebuilding my now 8+ year-old G&G mp5. Its performance is pretty much where I want it, however in auto, I am getting feeding issues.

    Being as old as they are, I suspected my mags were the problem, so I got new ones (Echo 1 mid-caps and a G&G hi-cap). While they fed better than the old ones, it's still noticeably skipping rounds in auto (semi feeds just fine). I understand Mp5 mags were never really known for feeding well. I'm open to trying a different kind of mag, but not sure what brands to go with these days.

    The next thing I tried was adding a sector delayer, which only resulted in breaking the tappet plate. I've since replaced the tapped plate and removed the delayer - the problem persists...

    What could I try next? I know I'm close, but can't quite figure it out.

    My build list is as follows, any parts not mentioned are stock:
    CYMA cylinder (I disabled the blowback system)
    SHS full metal rack piston (short stroked 3 teeth and AoE corrected)
    SHS M120 spring
    SHS 13:1 gears (short stroked 3 teeth)
    G&G ETU w/ Perun ETU++ MOSFET
    SHS High Torque Motor
    Guarder hard bucking

    My xcortech chrono has been reading 335-340fps and anywhere from 11 to 25 rps (probably due to inconsistent feeding) on .2g "Lancer tactical" bbs and an 11.1v lipo.
     
  2. yrutimid

    yrutimid Active Member

    578
    120
    Phoenix
    that rps seems really low for some reason
     

  3. Noah_6

    Noah_6 Active Member

    1,041
    7
    Burbank
    I can't even accurately measure it because of the feeding issue
     
  4. BeansOnToast

    BeansOnToast Member

    76
    9
    Seattle
    Is it a mag spring problem, or a nozzle/bucking problem? That is what you need to figure out. Try turning the gun over with the mag and chronoing that.
     
    Noah_6 likes this.
  5. Noah_6

    Noah_6 Active Member

    1,041
    7
    Burbank
    On it! I'll report back ASAP
     
  6. Noah_6

    Noah_6 Active Member

    1,041
    7
    Burbank
    The feeding issues persist even with it upside down
     
  7. yrutimid

    yrutimid Active Member

    578
    120
    Phoenix
    have you tried different hopup packings/rubbers
     
  8. aotsukisho

    aotsukisho Well-Known Member

    556
    333
    Have you tried using different brand and/or weight ammo?
     
  9. Noah_6

    Noah_6 Active Member

    1,041
    7
    Burbank
    The stock G&G rubber as well as the guarder one don't seem to be making a difference
     
  10. Noah_6

    Noah_6 Active Member

    1,041
    7
    Burbank
    I've tried some G&G .25g as well, but it still has the same problem.
     
  11. aotsukisho

    aotsukisho Well-Known Member

    556
    333
    Try loading your mags, point them into your bag/bottle and then pulling the bb retainer on them so the bbs shoot out. It will tell you if the mags are actually feeding properly with no interruptions as you will hear hesitation during the flow if the follower is binding around the internal bends.

    If you have a 2s lipo try running it on that, to see if the increased speed (and smaller feed window) is causing problems on 3s.
     
    Noah_6 likes this.
  12. Noah_6

    Noah_6 Active Member

    1,041
    7
    Burbank
    I tried that, they load up and eject all their bbs with no issues. Unfortunately, I could not find my old 7.4 lipo.
     
    aotsukisho likes this.
  13. yrutimid

    yrutimid Active Member

    578
    120
    Phoenix
    random question, do you have the stock gb in that mp5? my friend happens to have a g&g mp5 and i built him a gb.
     
  14. Noah_6

    Noah_6 Active Member

    1,041
    7
    Burbank
    Yes, I am using the stock gearbox because the dust cover won't fit otherwise.