G&G Scar-l problem

Discussion in 'Gun Building, Modifications & Repairs' started by Mathers23, Aug 28, 2012.

  1. Mathers23

    Mathers23 New Member

    96
    0
    Ok guys,I bought a g&g scar a week ago and when I shot it for the first time it would shoot about 30 ft and drop. I think the o-ring on the piston head snapped. Could any air smiths out there help me? Thanks a lot.
     
  2. L5132

    L5132 New Member

    1,175
    0
    Duluth
    Have you adjusted the hop up? That would be a more likely issue. Also, the bucking could be torn causing an air leak there.
     

  3. Mathers23

    Mathers23 New Member

    96
    0
    I've taken apart the hop-up already,it appeared to have no tear in it. Also I've turned the hop up and even then the gun still shoots all over the place.
     
  4. haml

    haml Member

    292
    0
    Somers
    Is it still only shooting 30ft or so?
     
  5. Mathers23

    Mathers23 New Member

    96
    0
    Not anymore. Today I got a new o-ring for the piston head and now it shoots fantastic.
     
  6. Mathers23

    Mathers23 New Member

    96
    0
    Ok so 2 days later the still shoots bad. Like the same as day 1. I really don't know what is going on internally.
     
  7. haml

    haml Member

    292
    0
    Somers
    Not to insult you but the cylinder is in correctly, right. Also, if it was shooting good 1 day and then you have the same problem the next just swap out the piston and cylinder. See if the same problem exists. Are you teflon taping the cylinder head? Its a compression issue it seems like. Also check you cylinder for bores, nicks and imperfections. Hope this helps. Keep us posted.
     
  8. Mathers23

    Mathers23 New Member

    96
    0
    I think I found the problem. When I put in the o-ring I found the air nozzle would spring back and forth when I pushed it. But when it shot bad the second time the air nozzle was stuck about half way. I think the air nozzle isn't going all the way forward causing a lack of air to push the bb through the hop up. I believe that's what is wrong but I could be wrong. And I've set everything in its correct position.
     
    Last edited: Aug 30, 2012