Gun Not Firing

Discussion in 'Electric Guns' started by I-Jet, Oct 22, 2021.

  1. I-Jet

    I-Jet New Member

    10
    0
    Phoenix
    I am brand new to airsoft, this is my first gun, and it is not firing. I have an ICS G33 AEG with a T-Plug, an Enrichpower Ni-MH 8.4 volt 1600 mAh nunchuck battery with a Mini-Tamiya, an adapter with a female T-Plug to male Mini-Tamiya, and a Tenergy smart AC charger for 8.4-9.6 volt NiMH batteries with a Mini-Tamiya. I got the gun secondhand at a garage sale (the guy I got it from said he only fired it once or twice) and everything else is brand new. So, I fully charged the battery, plugged it into the gun, turned the safety off, pulled the trigger, and nothing happened. I checked the fuse and it was fine, plugged the battery back in and made sure the it was correctly connected, and tried again. Still nothing. Can anyone help me with troubleshooting tips? Thank you for your time.
     
    Last edited: Oct 23, 2021
  2. Guges Mk3

    Guges Mk3 Administrator Staff Member Administrator Supporting Member Lifetime Supporter

    8,357
    4,726
    Minneapolis
    Check motor connectors to see if they are on and volt test the battery. Fully charged under no load you should be getting ~9.8V+.
     
    Ben3721 likes this.

  3. I-Jet

    I-Jet New Member

    10
    0
    Phoenix
    I tested the battery with a volt meter and it was pretty much fine. I found the motor connectors inside the grip and they seem firm. What could I try next?
     
  4. I-Jet

    I-Jet New Member

    10
    0
    Phoenix
    I plugged in the battery and when I pulled the trigger, the part of the motor that I could see in the grip moved slightly to the rear of the gun like it was being torqued like it's getting a little juice but not enough to do anything. What does this mean?
     
  5. Guges Mk3

    Guges Mk3 Administrator Staff Member Administrator Supporting Member Lifetime Supporter

    8,357
    4,726
    Minneapolis
    Pull the motor and hook up the battery...does it spin the motor outside of they grip?

    If it does...they wires on the motor may be wrong.
     
    Last edited: Oct 25, 2021
  6. Ben3721

    Ben3721 Well-Known Member

    725
    371
    Make sure it spins the correct direction outside the grip, doing so inside can damage the holes the anti reversal latch sits in.



    But how long have those batteries been sitting? Maybe they are messed up and don't hold much power anymore? Not enough to cycle at least
     
  7. OutlawAirsoft

    OutlawAirsoft Active Member

    287
    95
    Hamilton
    Also try adjusting your motor hight, it may be too tight. There should be a screw on the bottom of the grip you can adjust.
     
    Ben3721 likes this.
  8. I-Jet

    I-Jet New Member

    10
    0
    Phoenix
    So, when I did that, at first, the motor was too tight, but then, it loosened enough, but I couldn't hear the little thump of the piston moving forward again. I think something is wrong with the gearbox, am I on the right track?
     
  9. OutlawAirsoft

    OutlawAirsoft Active Member

    287
    95
    Hamilton
    Did it make a screeching/whining sound? If it did the screw is too loose and should be tighter.
     
  10. Ben3721

    Ben3721 Well-Known Member

    725
    371
    Seriously try a new battery. If that thing was sitting for a long time the battery is likely bad even if fully charged.
     
  11. Guges Mk3

    Guges Mk3 Administrator Staff Member Administrator Supporting Member Lifetime Supporter

    8,357
    4,726
    Minneapolis
    But now his motor height maybe messed up...
     
  12. I-Jet

    I-Jet New Member

    10
    0
    Phoenix
    So, at first, it was to tight to make any noise. I used a hex wrench to turn the set screw less than a half of a quarter turn at a time when suddenly, it started making a screeching/whining sound. Basically, if everything is fine with the motor and the gearbox, either I missed the right "tightness," or something IS wrong with the gearbox or the motor. By the way, I believe the battery is fine.
     
  13. Ben3721

    Ben3721 Well-Known Member

    725
    371
    Then if you believe the battery is fine have a tech work on the gearbox or work on it yourself if your comfortable doing so. Only 1 way to find out what's wrong at this point. Hopefully it's something minor.
     
  14. I-Jet

    I-Jet New Member

    10
    0
    Phoenix
    I'm guessing it is either the motor or the piston.
     
  15. OutlawAirsoft

    OutlawAirsoft Active Member

    287
    95
    Hamilton
    The motor hight is too loose. Tighten it back up to what it was. I hate to say this, but your gearbox is likely locked up.

    As Ben said, make sure your motor is spinning in the right direction and that the wires are on the correct terminals.
     
  16. OutlawAirsoft

    OutlawAirsoft Active Member

    287
    95
    Hamilton
    Could you post a video of the motor spinning outside of the grip? That may help us diagnose the issue.
     
  17. I-Jet

    I-Jet New Member

    10
    0
    Phoenix
    Ok, it will take me a while to do that because I'm not really able to do that myself (about the most I've done to take apart my gun is to take the handguard and the magwell off).
     
  18. I-Jet

    I-Jet New Member

    10
    0
    Phoenix
    I am working on getting the gun to a place that can look at it, but it might be a while before I can do that.
     
  19. I-Jet

    I-Jet New Member

    10
    0
    Phoenix
    Actually, I might just try to find a video on Youtube that can tell me how to fix it myself.
     
  20. I-Jet

    I-Jet New Member

    10
    0
    Phoenix
    By the way, does anyone know what the best airsoft teams are in the Las Vegas area (or which ones could use somebody with a G33)?