Gun problems

Discussion in 'Gun Building, Modifications & Repairs' started by lukiuxis, Nov 12, 2015.

  1. lukiuxis

    lukiuxis New Member

    2
    0
    Bray
    Hi, I have a jg g36c that I have been upgrading and recently I have ran into a porblem I hope some one can help with. I assembled the gearbox and attached the motor to test if it works and it shoots fine but when I put it inside the pistol grip/ lower receiver and try to fire it then nothing happens. I have no idea what is happening and why it doesn't fire as I have never had this problem before. I am hoping that some one will be able to help with this, thanks in advance
     
  2. MrGearbox

    MrGearbox New Member

    66
    0
    Peoria
    Maybe a little more info would be helpful. Is the pistol grip pretty tight when you put it on the gearbox? This could tug on a motor wire and pull it loose, off of the motor itself. And do you have the stock gearbox shell, or is it an upgrade one. Sometimes alignment issues will cause the trigger to be backspaced in the pistol grip and will not pull back all the way. However, these are just total guesses. Do you know of anything at all that you think might have changed to cause this during the upgrade? It might seem redundant but a PARTS LIST is ALWAYS helpful. Just some more info buddy so that people don't have to make blunt guesses.
     

  3. lukiuxis

    lukiuxis New Member

    2
    0
    Bray
    I figured out the problem, i had recently painted the pistol grip and got a new switch so the trigger was not going far back enough to touch the contacts inside the switch to work. I just filed away the plastic and it works fine now.
     
  4. MrGearbox

    MrGearbox New Member

    66
    0
    Peoria
    There you go that makes sense. Glad you figured it out! Take care!