Airsoft Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
hi, i need advice about repair of my cyma mp5k. lately I was changing broken tampetplate inside of gearbox, but when i assembled it back, it got stucked and cables and battery started overheating. firstly i thought that i made some mistake in gearbox (there was post about improper shimming so I checked that), but i could not find anything what could cause it to get stucked (all gears moved freely), only thing which come at my mind at this point was that there is something with motor. when I connected it without engaging gears it runned fine. but when I put it inside gun it was just overheating. so i changed spring and put in some spring I found home (realy weak spring, just to see if it can run) and it started shooting, but just about 5 meters (spring was weak so I didn’t expected anything else), so i concluded that motor cant push original spring I have inside, which is weird because before disassembling the gun it worked fine(just not feeding because of broken tampetplate). have someone similar experience and knows what to do or how to repair the motor?
i also send here photos of insides of gearbox (V2 i think) and photo of electromotor
Wood Machine Engineering Metal Auto part
Finger Nail Gear Thumb Electric blue
 

·
Registered
Joined
·
197 Posts
Checking your wiring harness for exposed wiring. A short (wire touching metal) can cause overheating. If it is your motor, ferrite motors like your current one are a dime a dozen so replacement is recommended.
 

·
Administrator
Joined
·
12,022 Posts
You cannot fix those motors easily, just buy a new one.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
that might be it, i will check it next week because I had to order new battery. I was using 7,4 V but coresponding battery to mp5k should be 9,6 V so that is propably part of problem with motor, height might be second part. thanks for advice
 
1 - 6 of 6 Posts
Top