KA M933 won't shoot?

Discussion in 'Gun Building, Modifications & Repairs' started by AceSOFT, Nov 25, 2015.

  1. AceSOFT

    AceSOFT Member

    32
    0
    Brunswick
    Hi everyone,

    I did a search and couldn't really find anything about my specific rifle (king arms M933 M4 'Ultra Grade') so if this is in the wrong place or a re-post please delete. I just bought this rifle about 2 weeks ago and shot it for the first time today and I noticed that it only shoots a BB once for ever 2-3 times I pull the trigger.

    Any ideas?


    More info:

    I load up the mag that comes with the gun and wind it, pull the trigger and it makes the loud "out of ammo" shot sound, so I pull the trigger another time and I get the quieter sound like I just shot a BB except nothing leaves the barrel, then I pull the trigger a 3rd time and a BB finally fires and may either go far or just sort of fall 4' away from the end of the barrel. I'm not understanding why this is happening, I've tried 2 different brands of mags now and it happens with both of them so I'm assuming it's not the mags, but either the hop up or something else. Any sort of help here would be greatly appreciated!
     
  2. Tactical_Skittles

    Tactical_Skittles Active Member

    1,071
    9
    Moscow
    Is your battery fully charged?
     

  3. MADR77

    MADR77 Well-Known Member

    1,454
    115
    Boise
    It could be that the magwell is too large for the magazine... Try positioning your magazine differently and see if the problem persists. It it continues you may need to purchase a new Hopup.
     
  4. bryanman

    bryanman Member

    632
    4
    Canada
    Clean the barrel, make sure hop-up is all the way off, try it again.
    Take a peep inside the magwell, make sure there's no crack in the GB.