KWA Sr-10 Not shoooting at all

Discussion in 'Gun Building, Modifications & Repairs' started by KoVNinjaX3RO, Dec 17, 2012.

  1. KoVNinjaX3RO

    KoVNinjaX3RO New Member

    69
    0
    Houston
    hey guys, i just received a kwa sr-10 from another member on this forum, and the gun isnt shooting. The gearbox cycles perfectly fine, and it seems to release enough air to push a bb like its supposed (i compared it to my other m4) but for some reason when i close it, it seems like no air is coming out of the barrel, and 1 out of every 10 or so shots, one or two bb's will fly out and fall about 5ft infront of me. I dont know really anything about kwa's but i would like some advice or solutions if anyone knows any. I took out the hop up, lubed it, switched the buckings and barrel, and nothing, same ole problem, and for some reason, idk if this is for kwa's but when i compared the air nozzles, the nozzle's tube in the kwa is about half the size of the one that is on my g&p, is this just the design of the kwa's or could some one have cut it, even though when you look at it, it doesnt seem cut, unless it was done with extreme precision, i could post of a pic of it, if anyone requests it. But yeah please help me!
     
  2. Ehudakineyah

    Ehudakineyah New Member

    2,510
    0
    Mililani
    You might have to take it apart sadly :/

    You could have sufferered from the rare "cylinder head" break lol :) it happens to KWA's sadly
     

  3. dylan484

    dylan484 New Member

    441
    0
    Tifton
    He said it produces the same amount of air as his g&p could be the air nozzle or tapper plate maybe?

    What do you think?
     
  4. Ehudakineyah

    Ehudakineyah New Member

    2,510
    0
    Mililani
    Well it could be.

    If his nozzle is moving back and forth. That will cancel out the tapplet plate and tapplet spring. Hopefully it's the right V2 tapplet plate as well.

    The nozzle should be the black KWA m4 nozzle with the hop up rib on top.

    Even if it is one of those 2 problems. He will still have to open up the gearbox lol :)

    And I'm hoping the hop up is installed correctly, and all the springs and etc and correctly installed.
     
  5. Bulldawg26

    Bulldawg26 Active Member

    1,179
    2
    Atlanta
    If the nozzle is moving normally and you are still losing compression, I bet you've got a cracked cylinder head. You'll have to open up the box to find out.
     
  6. Ehudakineyah

    Ehudakineyah New Member

    2,510
    0
    Mililani
    Thank you for quoting me lol ;) Jk Jk
     
  7. KoVNinjaX3RO

    KoVNinjaX3RO New Member

    69
    0
    Houston
    the hop up chamber is slightly cracked, and the unit is pressed firmly against the gb like it should be (i think) the only thing that i notice that is different is that when i look through the unit, i dont see the nozzle go through the unit like i do in my g&p, it just goes far enough to push the bb forward, but it doesnt seem like far enough to push it into the bucking, and i think that might be a problem because every 2 shots, one bb rolls out, the other one just gets stuck in the bucking until the next one fires, so i really dont know what to do
     
  8. Bulldawg26

    Bulldawg26 Active Member

    1,179
    2
    Atlanta
    Funny! I wasn't even paying attention to the other posts when I did that. Just reinforcing your point for ya. You're welcome. Jk :p