l96

Discussion in 'Spring Powered Guns' started by biohazardairsoft7, Oct 12, 2012.

  1. biohazardairsoft7

    biohazardairsoft7 New Member

    189
    0
    kittaninng
    hello i bought a used l96 i fired it like 3 time and now the bolt wont lock back it just shoots striaght forward .
     
  2. TYSONtheSNIPER

    TYSONtheSNIPER New Member

    1,939
    3
    Edmonton
    Sounds like slam firing. Might need new sears or a whole new trigger unit. Or it could be the piston. If you can open it up and check for any wear on both the trigger sears and piston.
     

  3. biohazardairsoft7

    biohazardairsoft7 New Member

    189
    0
    kittaninng
    Piston looks fine what are trigger sears
     
  4. TYSONtheSNIPER

    TYSONtheSNIPER New Member

    1,939
    3
    Edmonton
    In the trigger box you have sears.



    WRC134_01.jpg

    See that chunk sticking out at the front?
    It looks like this in most L96's.


    LXPSS2PS.jpg

    So take off your trigger box and inspect the sears, chances are it isn't catching on your piston properly due to it being worn out.

    Different rifles have different style of sears, so make sure you know what type yours takes exactly. You'll want a good quality steel replacement sear. What brand is your gun?
     
  5. ncore

    ncore New Member

    1,064
    0
    Pittsburgh
    This happened to my old l96. The trigger sears looked fine, but I guess something was wrong with the trigger box itself. If you don't want to buy an expensive top quality trigger mechanism, I think evike sells a pot metal one for $30. I got it and it works like a charm.
     
  6. TYSONtheSNIPER

    TYSONtheSNIPER New Member

    1,939
    3
    Edmonton
    Your pot metal sear will give out in time, especially if you have a strong spring.