Looking for help on my BAR-10 G

Discussion in 'Spring Powered Guns' started by rockurheart, Dec 13, 2012.

  1. rockurheart

    rockurheart New Member

    3
    0
    I have a problem on my BAR-10 G. After setting the sights and practicing on targets for hours, the gun starts to rebuke shooting after i cock it. The bb's go inside the chamber but they don't seem to be firing after i pull the trigger, though I hear the spring release, the bb just stays in the chamber and i have to take the magazine out and cock it once or twice more to get the bb in the chamber out. If i upgrade the gun and reassemble everything, will it solve the problem? Since it would be like a brand new one after assembling it back together again anyways after the upgrade to approximately 600fps.

    P.S: I just got this sniper rifle like 7 hours ago, pretty disappointed. I would appreciate all the help I can get. Thanks to all.
     
  2. dylan484

    dylan484 New Member

    441
    0
    Tifton
    May be your bucking, could have been a lemon. If your already having problems and haven't taken it apart, I'd send it back to who ever you bought it from for a replacement or your money back.
     

  3. rockurheart

    rockurheart New Member

    3
    0
    Hmm. Sending it back is kind of a complicated process for me at the moment. Is there anything else that i can do or might be causing this? :(
     
  4. TYSONtheSNIPER

    TYSONtheSNIPER New Member

    1,939
    3
    Edmonton
    I posted this in that other thread, but seeing as you have this one I'll put it here too.