M4 repair, help needed!

Discussion in 'Gun Building, Modifications & Repairs' started by FreedomMassacre, Oct 22, 2012.

  1. FreedomMassacre

    FreedomMassacre New Member

    10
    0
    Bristol
    Ok I bought a jg m4 ris s-system from airsoftmegastore.com. When I got the gun I charged the battery and loaded the clip. After a while when I went to test it and the gun wont shoot properly. On full auto the gun shoots one time then just makes the sound like it is shooting but nothing comes out. At first I thought the clip just wasnt working properly and bought a new clip but this didn't solve the problem. If anyone knows whats wrong and can give me the steps to fixing it I would be very appreciative!
     
  2. airsoftplayer14

    airsoftplayer14 New Member

    913
    0
    Buy a new Hop up and push your mag forward and shoot it and see what happens. If this doesnt work i suggest a new hopup.
     

  3. marine121496

    marine121496 Wahahaha~ Supporting Member

    7,506
    2
    Ann Arbor
    ??It's not the hop up by default??

    OP:check if your air nozzle is moving back and forth every time you shoot.
     
  4. FreedomMassacre

    FreedomMassacre New Member

    10
    0
    Bristol
    If you mean look though tje hole where the mag.goes yeah it moves
     
  5. Batman

    Batman New Member

    1,554
    0
    Wichita
    did you wind the hi-cap magazine?
     
  6. FreedomMassacre

    FreedomMassacre New Member

    10
    0
    Bristol
    Yeah the clip is fully loaded and wound. Itll shoot the first bb then itll just sound like its shooting
     
  7. Killa24

    Killa24 New Member

    1
    0
    Springfield
    Hold the gun upside down and shoot I see I more bbs will come out?
     
  8. Finalencounter

    Finalencounter Duke of Penguins Supporting Member

    5,239
    0
    Warrenton
    First, the word you are meaning to use is mag, not clip.
    Second, like stated before, it may be the hop up. You say the air nozzle moves though?
     
  9. Batman

    Batman New Member

    1,554
    0
    Wichita
    Try turning down your hopup.
     
  10. FreedomMassacre

    FreedomMassacre New Member

    10
    0
    Bristol
    Yeah when I looked through the hole and pull the trigger it moves
     
  11. FreedomMassacre

    FreedomMassacre New Member

    10
    0
    Bristol
    And killa yeah when I turn it upside down it works fine
     
  12. dylan484

    dylan484 New Member

    441
    0
    Tifton
    I'd think it's your mag then. Shoot it while pushing your mag into the gun and see if that helps
     
  13. marine121496

    marine121496 Wahahaha~ Supporting Member

    7,506
    2
    Ann Arbor
    Ah yes wind your mag, and try to click it without having it in the gun, and see if bbs fly out.
     
  14. FreedomMassacre

    FreedomMassacre New Member

    10
    0
    Bristol
    Idk why lol but it works now after I pushed the mag in and held the mag uo further while shooting
     
  15. dylan484

    dylan484 New Member

    441
    0
    Tifton
    Try putting tape over the mag catch on the mag. Make sure you push the tape down into the catch. It should make the mag fit more snug.
     
  16. airsoftplayer14

    airsoftplayer14 New Member

    913
    0
    You are going to have to experiment with different brand mags then to solve this problem you can just buy an hop up which should solve the problem.
     
  17. FreedomMassacre

    FreedomMassacre New Member

    10
    0
    Bristol
  18. Archer627

    Archer627 New Member

    6,174
    5
    Figgington
    A new hop up will not solve the problem.......
     
  19. airsoftplayer14

    airsoftplayer14 New Member

    913
    0
    Why not maybe the hopup nozzle that reales the bbs is to short and maybe different brands have a longer nozzle?
     
  20. TheAirsoftTech

    TheAirsoftTech New Member

    3,510
    5
    What?
    The nozzle isn't the problem, if it shoots upside down and with the mag pushed in. By these tests, it's the mag.