My friend's v.2 gearbox has me stumped!

Discussion in 'Gun Building, Modifications & Repairs' started by shasta588, Sep 3, 2012.

  1. shasta588

    shasta588 New Member

    44
    0
    So my friend's dboys scar stopped working a while back, and he left it at my place for me to try and fix. The original problem was the trigger switch prongs, I guess you could say were separated so that the middle one wouldn't connect them. So I bent them back into place, tested it with the volt meter, and it worked. There must be another problem though, cuz when all put back together it won't cycle. I believe it has something to do with the tappet plate though, cuz the loading nozzle stays out so it's almost impossible to put the lower back into the upper. I've attached some pics, any insight would be great.

    image-3342116528.jpg



    image-1908590938.jpg



    image-2331036300.jpg
     
  2. TheAirsoftTech

    TheAirsoftTech New Member

    3,510
    5
    Does it sound like its shooting? Like the piston cycling and just not the air nozzle? Or is it not even cycling all around?
     

  3. shasta588

    shasta588 New Member

    44
    0
    It just doesn't cycle at all
     
  4. TheAirsoftTech

    TheAirsoftTech New Member

    3,510
    5
    Maybe it's shimmed to tightly?
    I just accidentally shimmed a GB to tightly myself yesterday, I shim gearboxes all of the time too.
     
  5. shasta588

    shasta588 New Member

    44
    0
    That is a possibility, although I haven't touched the shim job at all. Would there be a good way to tell if that's the issue?
     
  6. marine121496

    marine121496 Wahahaha~ Supporting Member

    7,506
    2
    Ann Arbor
    Open it up remove the cylinder, tappet plate spring, and spring guide. Then stick your finger through the gearbox and try to spin the gears.
     
  7. TheAirsoftTech

    TheAirsoftTech New Member

    3,510
    5
    If an 8.4v won't pull it, but a 9.6v will. That's how I did it. But, then again, if you haven't touched the shims that shouldn't be the problem. Also, check the motor connections and fuse.
     
  8. shasta588

    shasta588 New Member

    44
    0
    Done, gears spin perfectly
     
  9. TheAirsoftTech

    TheAirsoftTech New Member

    3,510
    5
    Hmmm, did you check the motor connections to see if they're loose? Or the fuse?
     
  10. shasta588

    shasta588 New Member

    44
    0
    Checked all the connections with the volt meter, they all read fine
     
  11. TheAirsoftTech

    TheAirsoftTech New Member

    3,510
    5
    Are the trigger contacts in good condition? Are they also free of any grease?
     
  12. shasta588

    shasta588 New Member

    44
    0
    Yup, they were the original problem, so when I reopened it, it was the first thing I checked
     
  13. TheAirsoftTech

    TheAirsoftTech New Member

    3,510
    5
    I don't know then, maybe there's a loose wire, pinched, or bad wire..
     
  14. shasta588

    shasta588 New Member

    44
    0
    So I put it all back together, and it's definitely not an electrical problem, it started working, but was only able to pull the piston back a little bit before it jammed. The tappet plate did get pulled back this time, so that might be ruled out. What do you think?
     
  15. TYSONtheSNIPER

    TYSONtheSNIPER New Member

    1,939
    3
    Edmonton
    First time I opened up a gearbox I had the same problem. The solution for me was to make sure the sector gear was in the one o'clock position.
     
  16. shasta588

    shasta588 New Member

    44
    0
    Hmm, never even thought of that! What exactly is the one o'clock position for it? (I understand how clock positions work, I'm just wondering where you measure it by on a completely round gear)
     
  17. TYSONtheSNIPER

    TYSONtheSNIPER New Member

    1,939
    3
    Edmonton
    Well I used that nub thing that pulls back on the tappet plate.
     
  18. shasta588

    shasta588 New Member

    44
    0
    Ok, I was trying to go by the teath... Lol that didn't work so well...
     
  19. Kmkraft12

    Kmkraft12 New Member

    916
    0
    Gainesville
    I knew that was it. Haha. OP. You probably broke the soldering off of the trigger contacts when you bent them. Try re soldering them.

    It could also be a miss placed anti reversal latch.
     
    Last edited: Sep 3, 2012
  20. TheAirsoftTech

    TheAirsoftTech New Member

    3,510
    5
    Lol, it was like two .2 shims to tight.
    :mad: