my gun wont fire?

Discussion in 'Electric Guns' started by The_Flash20, Feb 3, 2011.

  1. The_Flash20

    The_Flash20 New Member

    57
    0
    Macclenny
    i have an aftermath kraken, i accidently burnt out the first battery so i bought a new one, 8.4v 1600mah, i charged it for 4 hours and 45 minutes which so i know i didnt burn this one out i put it in my gun and nothing happened, no moving gears or motor, not even a single sound.
    I bought a new fuse for it but still wont do anything?
    is there a certain fuse i should use for it?
    the original was a 30a 250v the new one i used was a 30a 32v idk where to get larger fuses from?
    ive even disassembled it and just hooked the mechbox individually to the battery and still there was no noise or even any movement suggesting that power was getting to it?
    please help haha i havent even been able to play a single game with this yet
     
  2. klinefrog

    klinefrog New Member

    2,013
    0
    Costa Mesa
    its definetly electrical. If you can plug your battery into another gun and go from there. Was the original fuse blown?
     

  3. The_Flash20

    The_Flash20 New Member

    57
    0
    Macclenny
    i would do that if i had another gun to plug it into and no i dont think it was i didnt see any breaks in the filament, but just for process of elimination i did i still have it though.
    ill probably have to have someone else look at it im not comfortable taking the gearbox itself apart
     
  4. klinefrog

    klinefrog New Member

    2,013
    0
    Costa Mesa
  5. The_Flash20

    The_Flash20 New Member

    57
    0
    Macclenny
    thanks ill look at that one for sure, but i have done that i put the new one in and the old fuse in several times alternating like that and still nothing happened, im getting another gun in the mail this saturday that takes the same kind of battery so im going to test my new battery in it to see if its for sure my old gun. every where i look tho it says to charge it for that long and if i followed the charge time formula that people have sent me the, battery mah divided by the carger output ma, i would be charging it for like 6 hours according to that.
     
  6. klinefrog

    klinefrog New Member

    2,013
    0
    Costa Mesa
    that is never a accurate charging time, its more of guidelines then anything. I would just pick up the cheap smart charger i linked you. it maybe a broken wire somewhere. If your other gun doesnt work on your battery then you have a dead battery
     
  7. alex

    alex New Member

    4,794
    3
    Atlanta
    i worked on a KWA m4 that didn't fire. the owner thought it was an electrical problem. i first tested to see if the motor spins without the cover on. it did. the gear box was locked up because the piston head broke off and wedged inside the cylinder.

    on another no fire AEG, the trigger contacts were burnt.

    and on another (KWA), the trigger contact block stop pole was broken and wasn't able to latch on to the trigger lever.

    use a volt meter to test for voltage throughout the wires. also use the volt meter to test the battery.
     
  8. The_Black_Knight

    The_Black_Knight New Member

    698
    0
    I don't know how Aks motors go in but check the motor and see if both wires are attached, my gun broke this past summer and that was the problem with it, fixed it and it has worked fine ever since.
     
  9. The_Flash20

    The_Flash20 New Member

    57
    0
    Macclenny
    thanks for all the help and advice im probably just going to let someone else who really knows what they are doing look at it cus i dont have the skill nor the patients to work on the gearbox haha