Need Help! Gate Merf Problem

Discussion in 'Introductions' started by TheAirsoftEnthusiast, Jul 19, 2015.

  1. TheAirsoftEnthusiast

    TheAirsoftEnthusiast New Member

    2
    0
    Minneapolis
    Hello, I had a Gate Merf 3.2 advanced mosfet installed into my gun (KWA sr-10), and right after installation when trigger pulled, Instead of shooting, the gun would go into program mode. The tech said he thought it was the motor so he tried putting in another one to see if it would shoot. It fixed the problem (as so I thought at the time.) So after 3 months pass and a couple of target shooting with it, I decide to go out and field it. Just my luck, the first game after 100 rounds the problem starts to occur again. I was majorly confused. Every time I pulled the trigger with the battery installed,the mosfet would not fire. But instead go into program mode. So thinking "Oh crap Do I really need a new motor again?, I've barley put 1000 rounds through this one?" So i take it out and put it in my friends gun m4, and it works just fine. I put his in mine and the problem still occurred. So I have come to the conclusion that something was way wrong with the mosfet.(obviously) So what Im trying to say is that i'm stuck. I gave put $200+ plus on internal upgrades to the gun, and I'm not sure if I want to continue to spend money on it. That is because My gun has been broken longer than it has been fixed. It worked fine stock, but I have things from springs snapping to wires melting, to having my trigger contacts explode. Does anyone know, or have a theory to a solution? If not than I am considering buying an HPA system.
     
    Last edited: Jul 19, 2015
  2. Steve116277

    Steve116277 Member

    209
    5
    North Alabama
    Welcome to the forum. There is a tech section. Put your question there and you should receive good feedback.
     

  3. Kopis

    Kopis Active Member

    3,197
    9
    This doesn't sound like a motor issue to me. Im thinking wiring and replacing your motor may have fixed it for a bit.


    Buy my UBR, 60 +shipping CONUS