P90 Semi-Auto

Discussion in 'Gun Building, Modifications & Repairs' started by cool4christ, Jan 4, 2013.

  1. cool4christ

    cool4christ New Member

    328
    0
    I remember reading about the P90 having problems shooting full auto all the time. Something about the cut off lever would wear down? Can someone tell me the fix for that? Or post a link to the thread? I have searched and have had no luck finding it.
    Thanks for any help,
    Cool4Christ
     
  2. Flocktime

    Flocktime New Member

    750
    0
    NukeTown
    Replace the cut off lever. Are you having this problem or is it someone else? What P90 are we talking about. I don't hear a lot about that happening.
     

  3. Lefse

    Lefse Well-Known Member Supporting Member

    6,148
    1,772
    This issue can also be caused by the contacts being too far apart in the primary trigger switch. To fix this you simply have to open it up and bend the contacts a bit closer.
     
  4. cool4christ

    cool4christ New Member

    328
    0
    The trigger contacts are fine. And it's a brand new gun but I don't remember the fix for the cut off lever. It looks to me as if the spring is not strong enough to push it back into position. I will post a picture shortly.
     
  5. gunblazer

    gunblazer New Member

    41
    0
    Daly City
    my cutoff lever is worn out, only moves if i spin the gear by hand. But before it got worn, semi didnt work before anyways due to the contact wearing out.
     
  6. RapidFire300

    RapidFire300 New Member

    17
    0
    The gearbox might be jammed that or the sprocket might be too greasy