[Please Help] KWA Glock is not functioning

Discussion in 'Gun Building, Modifications & Repairs' started by catkaze, Dec 18, 2018.

  1. catkaze

    catkaze Active Member

    221
    38
    Jacksonville
    A long time ago, I traded with someone for their KWA Glock. I knew it had some issues, but I love the gun and its look. Unfortunately, it is not functioning at all. The issue I am having is when I try to shoot it, the slide only blows a little bit back and a lot of gas is released out the barrel. I have replace everything I can think of. I have replaced the loading nozzle, the valve inside the loading nozzle, the springs for the loading nozzle, and the hammer spring. I am an AEG tech not a GBB tech, so I could very well have missed something, which is why I am turning to you all. I'm out of ideas, so I will appreciate any suggestions for what I can do to get this thing working again.
    Thanks for reading!
     
  2. Guges Mk3

    Guges Mk3 Administrator Staff Member Administrator Supporting Member Lifetime Supporter

    8,163
    4,632
    Minneapolis
    Light striking hammer. Did you replace the hammer spring?
     

  3. The_Jelly

    The_Jelly Active Member

    148
    45
    Upon reading the OP's post it says he did replaced the hammer spring. Maybe an incorrect spring replacement? Subbing as I would like to know what the fix is for reference.
     
  4. Guges Mk3

    Guges Mk3 Administrator Staff Member Administrator Supporting Member Lifetime Supporter

    8,163
    4,632
    Minneapolis
    Post pictures of the underside of the slide please.
     
  5. catkaze

    catkaze Active Member

    221
    38
    Jacksonville
    IMG_1545168436.953159.jpg
    As requested, here is the underside of the slide. If it helps, I replaced the hammer spring with a "reinforced" hammer spring from Evike.
     
  6. fred_ditto

    fred_ditto Well-Known Member

    1,078
    627
    Des Moines
    aaaaaaaand... that could be your problem right there.What brand? Check out Rainbow8, they have good stuff for pistols. Their shipping costs and time from Hong Kong are surprisingly good.
     
  7. catkaze

    catkaze Active Member

    221
    38
    Jacksonville
    I'm almost certain it was guarder, which is the first result I could find on Rainbow8. Is that not a good brand? What brand do you recommend?
     
  8. fred_ditto

    fred_ditto Well-Known Member

    1,078
    627
    Des Moines
    In that case, Guarder is a good brand. Maybe AIP?
     
  9. Thai

    Thai New Member

    26
    12
    Durham
    -Check the pin that secures your rocket valve inside the nozzle (part 26)- did you super glue it in place? If it's misaligned, the BBU will not channel gas appropriately. You pretty much HAVE to super glue it every time you reinstall it- don't worry, the plastic is generally smooth enough that it's not actually permanent, it just keeps it in place under the violence of the blowback. I noticed from your pics you're using an aftermarket part: is that angel custom? In that case, it might be ATP spec, which in my experience can be ever-so-slightly different from the KSC glock spec (it's a good idea to swap in the stock part if you have it and see if that fixes it. The stock nozzle is pretty much never going to break anyways unless you get a jam on metal bb's)

    -Check your valve knocker (part 78). If that's broken, your hammer won't push the striker properly and the thin part that the spring hooks on to is prone to breakage, especially if you live in an area with cold weather as it makes the metal brittle. You can try your luck with the angel custom steel part but ideally you'd locate the Shooter's Design steel replacement part, which is really, really hard to source (I had to order mine from South Africa!) . OR, you can order a couple spares of the stock part from Rainbow 8: you might just get lucky and get one that lasts a really long time as they're all a bit different. Mine took about 10 years to fail and I shot it when it was snowing outside (bad idea...)
     
  10. Thai

    Thai New Member

    26
    12
    Durham
    One more thing that can be wrong, but this is rare: check the top pin on your magazine that secures the feed lips (part 208): if this is bent, the gas route won't make a good seal and you'll get incomplete cycling. This one is easy to diagnose- if you have more than one magazine, the other ones will work while the bent pin mag won't!