Richman992's EBR thread

Discussion in 'Gun Building, Modifications & Repairs' started by richman992, Aug 20, 2012.

  1. richman992

    richman992 New Member

    1,366
    0
    Rochester
    Ok, so I finally managed to get my hands on one, but it needs some work. Luckily, the guy I bought it from thought it worked and offered to pay for any new parts it might need, since it wasn't working as he said it was.

    It isn't feeding, and the nozzle doesn't move, which leads me to believe its the Tappet Plate being out of alignment. However I'm not sure, and I've never worked on an m14 so I was hoping maybe some folks would have some input as to what the problem is. It still cycles and i can feel the pop of air come out of the barrel, so im not 100% sure what that means. I will post gearbox pics when I get it open.

    Also, there isn't a whole lot of lower rail space, does anyone know of a way to get a m203 or some sort of grenade launcher on it? I thought of installing rails on the handguard but I feel like it wouldn't work because it's where the battery goes...

    BTW, this is the Kart model EBR.

    Thanks in advance for the help
     
  2. richman992

    richman992 New Member

    1,366
    0
    Rochester
    Sorry for the double post. Managed to find a way to get my gearbox out finally, but the damn screws next to the selector switch are completely stripped. Anybody have any ideas? I can't get enough of a grip on the screw head to even remove it. How absolutely irritating.
     

  3. INFANTRYPRO

    INFANTRYPRO New Member

    598
    0
    Alright well it does sound like its the tapet plate. I wouldn't take it apart though since they're the biggest pain to take apart.
     
  4. Mystery43_4

    Mystery43_4 New Member

    1,307
    1
    Santa Barbara
    It's most likely a broken tappet. What happens when you press the air nozzle in?
     
  5. richman992

    richman992 New Member

    1,366
    0
    Rochester
    too late, I already got the gearbox out, haha. there just wasn't an EBR disassembly vid on YouTube so it was difficult to figure some stuff out.

    @mystery: it has some play to it, but it's not like it moves back and forth freely.
     
  6. Adman234

    Adman234 New Member

    3,024
    8
    Wildwood
    Yep, get a screw removal tool from home depot, and some new screws. Sounds like tappet plate issue to me, can you feel a spring pushing back when you push in the nozzle?

    I have an m203 with no mounts, but it has threaded holes, perfect for making your own mount for the m14. Pm me if you want it.
     
  7. pancakemix56

    pancakemix56 New Member

    1,736
    0
    Boston
    Have no fear, pancake is here! I am the MASTER of stripping screws and screw removal kits... Work, but I found a method that is cheap and works better in my opinion.

    Take a rubber band and cut it once so it's a piece of rubber string. Cut in half (width wise) if needed. Then, simply put the middle of the band on the screw, press the screw driver in, and whala stripped screw no more! :)
     
  8. richman992

    richman992 New Member

    1,366
    0
    Rochester
    Yeah, it feels like there is some resistance, and when I push it in, it doesn't go in all the way, and it springs back out if I let go of it.

    As for the m203, if I can get this all figured out, I'd be interested.
     
    Last edited: Aug 21, 2012
  9. richman992

    richman992 New Member

    1,366
    0
    Rochester
    A quick update: No luck removing the screws, so since the guy I bought it from is a tech he's going to take care of it for me this weekend. And then we can figure out whats going on inside of it. Still thinking its just a Tappet failure.

    I was looking into grenade launchers and noticed this one. I'm wondering if it would fit better on the EBR since I know the AK has pretty limited lower rail space as well. I know it probably won't look GREAT, but that's not really a big concern.

    http://airsoft.tiger111hk.com/p2061...uncher-For-AK-Series(Black)/product_info.html
     
  10. richman992

    richman992 New Member

    1,366
    0
    Rochester
    The Tappet is fixed and everything is working fine. However getting this thing back together is a rather daunting task. Does anyone know of a tutorial I can watch, or maybe have some tips that might help? There's EBR parts everywhere...

    EDIT: I got it together, and firing, but it only feeds once every few shots. what did I do...?
     
    Last edited: Aug 26, 2012