TM Glock 17 Issue (Video)

Discussion in 'Gun Building, Modifications & Repairs' started by mikenike, Aug 6, 2012.

  1. mikenike

    mikenike Member

    379
    0
    I was selling it when I thought I fixed this, but apparently not. Not going to sell someone a TM pistol with issues =S

    So. My slide just gets stuck back, like you see in the video.

    I have no idea what can be causing it. I'm legitimately clueless.

    If I slide the slide back and pull up on it a bit, it just gets stuck back.

    I'm in desperate need for help.

    It's like new, apart from this issue. Only put around ~200 rounds through it (as of today).

    It still fires perfectly and slides perfectly (when I'm pushing down on the slide).

    I can't sell it until this is fixed.

    VIDEO:

    [ame="http://www.youtube.com/watch?v=p68-X85ZGFI&"]http://www.youtube.com/watch?v=p68-X85ZGFI&[/ame]
     
    Last edited: Aug 7, 2012
  2. Adman234

    Adman234 Active Member

    3,024
    9
    Wildwood
    Maybe it's getting stuck on the internal hammer?

    I've only opened ksc glocks...
     

  3. adas1223

    adas1223 Well-Known Member

    1,544
    864
    stratford
    "marui glock zero hammer"
     
  4. mikenike

    mikenike Member

    379
    0
    Last edited: Aug 7, 2012
  5. TYSONtheSNIPER

    TYSONtheSNIPER New Member

    1,939
    4
    Edmonton
    Check your loading nozzle spring. It could be messed up. First though take your slide up and pull your loading nozzle forward, if it springs back that might not be your issue. If it remains stuck forward the spring could be your problem.
     
  6. mikenike

    mikenike Member

    379
    0
    That's not the problem.
     
  7. adas1223

    adas1223 Well-Known Member

    1,544
    864
    stratford
    put some silicone on, more than usual. if that fixes it for a while, go to town polishing the friction points.

    seems like you fixed it though, racking your slide 120 times.

    good job
     
  8. mikenike

    mikenike Member

    379
    0
    I didn't actually rack it 120 times, why would I do that. More like 30 ish. To see if the problem was gone for good.

    It still fires, it still racks when i'm pushing down on it. But doesn't when I pull up.

    I can't tell where the friction points are...

    [ame="http://www.youtube.com/watch?v=nom1oVqXayg&"]http://www.youtube.com/watch?v=nom1oVqXayg&[/ame]
     
  9. Thatguyoverthere1111

    Thatguyoverthere1111 New Member

    4,838
    0
    Mandeville
    Do NOT put anymore silicone than usual.... That won't help. Did you check the slide catch and see if it isn't warped?
     
  10. adas1223

    adas1223 Well-Known Member

    1,544
    864
    stratford
    waaaaaaaaaaaaaaat

    ..at least its fixed
     
  11. mikenike

    mikenike Member

    379
    0
    Yeah... I "said" I did. In my last thread.

    It's NOT fixed. :confused: