Trigger locks up on full auto

Discussion in 'Gun Building, Modifications & Repairs' started by Caleb3814, Jul 9, 2015.

  1. Caleb3814

    Caleb3814 New Member

    9
    0
    Hey guys, I've searched quite a lot for this and I haven't found anything yet relating at all to my problem.

    I recently replaced my trigger contacts (specifically the trolley) and I'm now running into some problems.

    When my gun is outside the body it's completely fine, I can move the selector plate by hand with no trigger problems at all. However, when I put the gearbox back into the body and try to pull the trigger on full auto mode, the trigger either locks up or pulls back and just makes a clicking sound.

    I have checked my selector plate and there's no signs of wear at all. Also my trigger works fine in semi auto mode, I'm really stumped as to what this can be. Any suggestions?

    Caleb.
     
  2. IIISonny

    IIISonny New Member

    43
    0
    Saint Paul
    Just the trolley was replaced? Or the whole thing?
     

  3. Caleb3814

    Caleb3814 New Member

    9
    0
    Just the trolley. I swapped it back for another g&g one and the problem has been solved. Still, I'd like to know if it was a problem with the shs trolley for future reference?
     
  4. smiles

    smiles Active Member

    806
    29
    fleetwood
    Why did you replace the trolley originally?
     
  5. Caleb3814

    Caleb3814 New Member

    9
    0
    Gun would not fire at all, the trigger contacts were built up with carbon. I think it was due to too much semi auto.