VFC M4 not firing semi

Discussion in 'Gun Building, Modifications & Repairs' started by brokenarrow, Oct 6, 2012.

  1. brokenarrow

    brokenarrow Well-Known Member

    6,513
    593
    Meadville
    I have a VFC M4 that will fire full auto on semi and auto, WHAT IS THE PROBLEM?!?!?
     
  2. bal1

    bal1 New Member

    1,366
    0
    I have the same problem with my cxp its probably the trigger contacts,but my knowledge on working on guns is limited.
     

  3. brokenarrow

    brokenarrow Well-Known Member

    6,513
    593
    Meadville
    It has brand new wiring, but it won't go semi and the motor will only squeal
     
  4. bal1

    bal1 New Member

    1,366
    0
    Motor height possibly? As I said my knowledge is limited.
     
  5. GreenListerine

    GreenListerine New Member

    630
    0
    The squealing sounds like a motor height issue. The auto-only sounds like a cut-off lever issue
     
  6. Archer627

    Archer627 Active Member

    6,174
    6
    Figgington
    The auto on semi is a cut off, selector plate, or selector switch problem.
     
  7. paulitoo55

    paulitoo55 New Member

    1
    0
    Fontana
    I have this same problem. But, sometimes my trigger will get stuck and won't respond unless I pull it forward a little bit. It makes a "Click" and continues to fire full auto.
     
  8. Ehudakineyah

    Ehudakineyah New Member

    2,510
    0
    Mililani
    - Trigger contact might not be touching the cut off lever.

    - selector plate might not be engaging the cut off lever

    - might have a built up of "stuff" in the way of the trigger contact dolly
     
  9. Archer627

    Archer627 Active Member

    6,174
    6
    Figgington
    Man has it been a while since you posted. Nice to see ya back!
     
    Last edited: Nov 5, 2012
  10. Ehudakineyah

    Ehudakineyah New Member

    2,510
    0
    Mililani
    haha thanks man :) first time i signed in.... in forever and a half :)

    ill be on now :) nice to be back