WE Hi Capa 5.1 Problem.

Discussion in 'Gas Powered Guns' started by Arktic, Aug 28, 2012.

  1. Arktic

    Arktic New Member

    36
    0
    Cape Town
    hey guys.

    So this gun is really driving me mad now. After replacing almost everything inside the trigger housing and nozzle assembly it still wont work.
    What I have narrowed it down to is the top of the hammer is getting stuck between the back of the nozzle and the blow back unit. When you fire the gun shoots the bb but on its way back to battery the slide moving forward and the hammer sliding back into position gets hung up on that are and jams the nozzle.

    I have tried a different unit and it does the same thing, different hammer, different nozzle, nozzle return spring, trigger mech, frame etc etc.If I use a different 5.1 lower altogether it works obviously.

    Here are some pics to help identify the issue.

    [​IMG]

    The nozzle (in Red) and the Hammer (in Green). The hammer is getting stuck in that area behind the nozzle before the nozzle can return to its normal position. I have also streched the nozzle spring about to help it return faster but no luck.

    [​IMG]

    The nozzle stuck forward.


    Any help would be much appreciated as I dont have that much experience with pistols and diagnosing the problems.
    Arktic
     
  2. Knief

    Knief Moderator Staff Member

    13,850
    3
    Ann Arbor
    Have you done anything to your main spring?
     

  3. Arktic

    Arktic New Member

    36
    0
    Cape Town
    I tried it with one from another hi capa and it did the same thing, also tried with one from a 1911.