WE Hi Capa Problem

Discussion in 'Gun Building, Modifications & Repairs' started by Esoda, Sep 8, 2012.

  1. Esoda

    Esoda New Member

    470
    0
    EDIT: I can't figure out how to imbed images on this forum so here's a link to an album containing the pictures: (http://imgur.com/a/Nqn1h)

    So I recently bought a used WE Hi Capa on my local airsoft forums and the day I went to pick it up the seller had left the gun in is car during a warm day, and it was having some cycling issues. We figured the silicon just evaporated off the nozzle so I sprayed it and figured it'd be good. I finally got a chance to shoot it today and it's still having the issue. It shoots of the round but then the slide gets caught back in this position:

    Same deal, back by the hammer so you can see a bit better:

    It also seems like the nozzle is poking further out farther than it should as shown in these two pictures:

    I added more silicon to the nozzle but it was still having the same issue. I have to push the back forward in order to shoot another shot.

    I figured no big deal, the gun came with an extra slide so I'll put that on and it should be fine. Well unfortunately I had the same results with a completely different slide. I did some research and some people said lubing the mag at the gas release and feeding spot fixes this problem, still no dice.

    So I'm kind of at a loss for how to fix this, if anyone could help that would be great. Here's some of the data concerning the gun and the issue:

    Using propane adapter with silicon to power gun.
    The slide doesn't catch when I manually cock the gun.
    I've tried two different slides and get the same results, is this a magazine problem?

    If anyone could help me out that'd be awesome!
     
    Last edited: Sep 8, 2012
  2. shasta588

    shasta588 New Member

    44
    0
    Considering you tried both slides and came out with the same problem, I'd say it's most likely a mag thing. Which is a pain in the butt. I bought a kjw single stack 1911 with 2 mags last september, they were both leaky, and I just now got them working fully last week. I'm not exactly sure what's wrong with yours. Correct me if I'm wrong people, but it sounds like the release (I think that's what it's called) valve on the mag.
     

  3. MrAirsoft194

    MrAirsoft194 New Member

    233
    0
    Well I the same thing happens to my gun on a cold day it catches on the mag lip, check if it does. Also does it still do it even with no mags.
     
  4. Esoda

    Esoda New Member

    470
    0
    Hm. Well I ordered a new mag, so we'll see how that pans out. I guess I learned somewhat of a lesson for buying used.
     
  5. MrAirsoft194

    MrAirsoft194 New Member

    233
    0
    Just make sure it works before buying. That's one lesson.