we tech tt33 help, occasional slide resistance

Discussion in 'Gas Powered Guns' started by max45354, Nov 25, 2015.

Tags:
  1. max45354

    max45354 New Member

    5
    0
    Boca Raton
    Hello,

    So I just bought this new WE TT33 from Evike and when I got it in the mail there was a problem. every so often when I fired the pistol, the slide wouldn't be able to go all the way back. It's a locked breach design and the barrel is supposed to drop a few mm's. But on the occasional shot that causes the slide to get stuck, I noticed the barrel wasn't dropping. The barrel was dragging along the top of the slide because of it causing the slide to get stuck. So I'm wondering if theres anyway to fix this problem? I don't want to have to return this pistol because I really do love this gun and the hassle would be tremendous. Any help would be greatly appreciated!

    http://imgur.com/a/KLNcl

    Sincerely,
    Max W
     
  2. Noah_6

    Noah_6 Active Member

    1,045
    8
    Burbank
    If it's so new, it might still be under warranty. Why not contact Evike and request a RMA?
     

  3. max45354

    max45354 New Member

    5
    0
    Boca Raton
    I just didn't want to go through the stressful proccess, so I was wondering if there was a solution that I could try at home.
     
  4. bryanman

    bryanman Member

    632
    4
    Canada
    Have you tried oiling it?

    My Sig works in a similar manner if I understand correctly. It had a rough cycle at first, until wearing in. I also sanded the paint off the barrel assembly (orange tip, etc. etc.).
    I would say simply try lubing it up, see if the problem continues. If not, problem solved, maintenance is a must.
    If not, you may have to sand the rear of the barrel assembly SLIGHTLY.
    Try lube first.
     
  5. max45354

    max45354 New Member

    5
    0
    Boca Raton
    Understood, thank you for the recommendation. It's dark out so I will test it tomorrow and post again with the results. Happy Thanksgiving :D