Weird problem with gun

Discussion in 'Gun Building, Modifications & Repairs' started by Computertech, Jun 2, 2015.

  1. Computertech

    Computertech New Member

    1,181
    0
    Hey guys im having a weird problem with my ICS m4, when I pull the trigger nothing happens, I know my motor needs to be adjusted but I gotta do this first. I'm guessing its either a blown fuse or trigger contact. Any help will be nice.
     
  2. danerd

    danerd Well-Known Member

    877
    908
    Hartsgrove
    1. Is your battery charged?
    2. Is your battery any good?
    3. Check all of your connectors to see if they are good. Sometimes a wire may come a bit loose and break the connection.
    4. Like you said, your fuse may be blown. Check that. ICS rifles *should* still use a 30 amp automotive blade fuse. You can get those at virtually any auto parts store.
    5. It would be a good idea to check your trigger contacts, but those usually don't cause this problem.
    6. Check your motor connectors. If one of those was bent too far or too much, they will snap inside the heat shrink and cut the connection. You can tell if it snapped by simply applying a bit of pressure to see if it bends. If it bends easily, it probably snapped and needs to be replaced.

    I would use a multimeter when your battery is plugged in and thoroughly test every connection point on your gun to determine what is causing the problem, starting from your battery and working your way down to your motor connectors. Once you find a place where the current has stopped flowing, you have found your problem (Or at least one of them).

    Hope this helps :)
     

  3. Rushin

    Rushin Well-Known Member

    3,920
    32
    Kalamazoo
    It might also be a wire with the coating stripped off, thus causing a short.
     
  4. Computertech

    Computertech New Member

    1,181
    0
    Alright thanks I'll check it out tonight
     
  5. Computertech

    Computertech New Member

    1,181
    0
    Alright so I found out the problem [​IMG][​IMG]. This black thing connected to my motor is broken, how can I fix this. Id prefer if I didn't have to buy online. Would I be able to solder it on or should I buy a completly new wire?
     
    Last edited: Jun 4, 2015
  6. Rushin

    Rushin Well-Known Member

    3,920
    32
    Kalamazoo
    You can solder it on, I expect you're running tamiya plugs? Then you shouldn't see any noticeable difference.
     
  7. Computertech

    Computertech New Member

    1,181
    0
    So what would be the fix to it?
     
  8. Rushin

    Rushin Well-Known Member

    3,920
    32
    Kalamazoo

    Solder on a new connector.
     
  9. Computertech

    Computertech New Member

    1,181
    0
    Alright thanks I'm going to buy some stuff and see if I can fix it tomorrow
     
  10. Computertech

    Computertech New Member

    1,181
    0
    Raven can you re link that, it only brings me to the website.
    Or do you think I could solder on the broken piece
     
    Last edited: Aug 30, 2015
  11. DreadCo526

    DreadCo526 New Member

    315
    0
    Sylvester
    No your going to need a new one. Brill armory and clandestine both have them if you cant get the link for digikey. You could solder the old piece back on but it wont last vary long, also be careful if you do solder the old piece back on not to use to much solder or flux as it will run down in the connector channel, causing a lot of fitment problems.
     
  12. Raven1st

    Raven1st Well-Known Member

    5,521
    444
    San Ramon valley
    Give me a bit and I'll get new links.
     
  13. BoogerMc

    BoogerMc Airsoft Jedi Master Supporting Member

    4,821
    239
    Akron
    Last edited: Sep 2, 2015