Airsoft Forum banner

Zion Arms Nebula Mosfet not able to shoot

1277 Views 4 Replies 3 Participants Last post by  Smokyband8t
I'm trying to see why the gun isn't letting me program the mosfet.
I install the battery, then it gives me a beep. Now it should beep when I use the semi auto, to Full auto (2x). But that is not working. It should give me a beep when its on program mode.

The manual doesn't show a lot so I attached the mosfet and it does work, but only 100 shots then it goes limp. I changed the battery and its the doing the same.
I added the switch plate which has a little sensor, and its still not working right.
See attached.
Probably I'm doing something wrong haha


See less See more
1 - 5 of 5 Posts
Did you ever figure this out? I’m having issues as well
I’m having the same issue too. It will shoot in semi auto and on the full auto selector but it won’t program to different trigger settings…
UPDATE I looked into why my mosfet was not programming after doing the “semi—>auto 2X” function. I proceeded by taking my gear box out and looking at my switch plate - it was completed cracked in half. I was able to fire in semi and auto still but could not program. I’m assuming the broken switch plate is preventing the program mode function. I ordered a new switch plate - I will update this after I install it and see if it works.

@Seananamous @anthonytkarney28 have you been able to come up with a fix, yet?
Did you ever figure this out? I’m having issues as well
UPDATE I figured out what the issue was! I removed the upper and lower receiver and extracted my gearbox. I inspected it and noticed right away that my safety selector plate was broken in half! I ordered one, received and installed the new selector plate. Put everything back together and tried the programming function, and it once again worked!
  • Like
Reactions: 2
1 - 5 of 5 Posts