Airsoft Forum banner

Zion Nebula MOSFET issue

181 Views 1 Reply 1 Participant Last post by  Smokyband8t
Hey all!
I have a Lancer Tactical Gen 3 with the standard Zion Nebula MOSFET programmable trigger. Does anyone know why all of a sudden it’s no longer programming different fire rates? I do the switch 2X from semi to full auto, but there are no programming beeps. Seems like it could be a selector switch malfunction? Any help or leads would be appreciated!
P.S. It’s all stock never taken apart or modified.
1 - 2 of 2 Posts
UPDATE I figured out what the issue was! I removed the upper and lower receiver and extracted my gearbox. I inspected it and noticed right away that my safety selector plate was broken in half! I ordered one, received and installed the new selector plate. Put everything back together and tried the programming function, and it once again worked!
During my initial research I found little to no information on a fix for this issue, so I wanted to share it with people who may be experiencing the same issue with Lancer Tactical Gen 3 mosfet malfunction.
  • Like
Reactions: 2
1 - 2 of 2 Posts